Skip to end of metadata
Go to start of metadata

System requirements

Currently Ariane is using Java 1.7 (Oracle version) and Python 3.3. It is daily tested against Linux O.S. Some time tested on AppleOS.X. We didn't validate Ariane on any Microsoft O.S.

To install Ariane on any of the tested O.S. you consequently need to install a Java runtime 1.7 and Python 3.3.

Database requirements

Ariane is using two SQL databases (one for Ariane IDM module and one for Ariane Directory). We're testing Ariane daily on MariaDB 5.5 and so we recommend it to install Ariane. 

Currently the Ariane Graph Database is embedded within Ariane distribution (Neo4j 2.1.2). That will change for sure in future Ariane releases.

Messaging requirements

Ariane is beginning to use RabbitMQ for external injectors. This is not a mandatory requirement.

 

  • No labels